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1 Introduction 
MPLOT is a simulation waveform visualization function. It can be started for the current design by:  

a. double-clicking on its button (icon) that can be dragged in from the options library 
b. clicking on the “View Scopes with MPLOT” button in the Simulate ribbon of EMTPWorks. 
c. right-clicking in the design and selecting MPLOT. 

When the MPLOT button is placed into a design, it will always open the web shown in Figure 1.  
 

 

Figure 1 MPLOT data web from the 

MPLOT
 button (double-click) placed into a design 

This web allows selecting Base Case simulation waveforms or/and Statistical simulation data.  
 
If the top level file is the design file: mydesign.ecf, then it will have a project folder named mydesign_pj. The 
project folder contains the Plot file attached to the last simulation run or other Plot files saved by the user from 
previous runs. The Plot file attached (resulting from) to the last simulation run is named mydesignm.m. This is 
the file used by MPLOT to load data. This ASCII file is internally referring to the attached binary file 
mydesign.mda which holds all the requested waveforms. 
 
The “Extra tagged files” section allows selecting other simulation Plot files previously saved by naming a tag. 
Tagged Plot files are created using the menu “Simulate>Advanced>View Output Files” and the Copy option. 
The tags used in the Copy option can be selected here by adding one or more tags in the data field below the 
“Extra tagged files” checkbox. If several tags are selected they must be separated by ‘;’, such as: 1;new. This 
is indicated by the data field tooltip.  
 
In the “Extra files” section it is allowed to name extra Plot files to be simultaneously opened in MPLOT. 
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Once the user clicks on the OK button, the MPLOT function starts and automatically loads the selected files. It 
also has a “File” menu that can be used to load more files if needed. The files loaded by MPLOT have the 
extension “.m”. More information on available Plot files can be found in the Help section of the menu 
“Simulate>Advanced>View Output Files”. 
When the MPLOT button is not present in a design, then EMTPWorks will directly open the MPLOT program 
window shown in Figure 2. 

2 The MPLOT function 
MPLOT is entirely written using MATLAB®. It is the compiled version of a set of m-files. It is also available as a 
free download for users who want to used MPLOT directly from MATLAB. The non-compiled MATLAB code 
provides much more options and can be used in conjunction with other programs in MATLAB. 
 
The MPLOT function is called using the plot file names as arguments. For a given design mydesign.ecf it is 
automatically called by EMTPWorks using the command: 

mplot mydesignm.m 

The same command can be used directly from MATLAB. In addition to the file name, EMTPWorks provides the 
full path of the file, which is also recommended if this function is used in MATLAB. It is allowed to enter several 
arguments if it is needed to load several files at MPLOT start. When started with no arguments, MPLOT allows 
opening files from its main panel (program window). 

2.1 The main panel 
The main panel of MPLOT shown in Figure 2 is its main GUI for accessing data and selecting the scopes to 
visualize. The user can identify various sections and button functions through tooltips (drag the mouse over a 
command or area). 
The main data area to the left is the area that lists available “scope names for the selected scope type”. This is 
from where the required scopes can be selected for visualization. The selections must appear in one of the 
areas to the right of this GUI to be accessible by various plot function calling buttons. The variable type is 
actually the scope type (group). 
 
The following sections are available: 
 

Selected y variables Variables that will appear on the y-axis. There is no default. 

Selected x variables Variables that will appear on the x-axis The default is taken from the type of 
simulation. 

Selected z variables Variables that will appear on the z-axis. There is no default. 

 
The default x-axis variable is also available for selection by choosing it from the dropdown menu of “Scope 
type (group)”. This is the last variable in the list. 
 
The number of selections in all 3 axis must be the same. Some plot functions operate only on the y-axis 
selections. If there is no appearing selection in x, then it is automatically given the correct number of default 
selections. This works also when the variables in the y-section are from different files. 
 
To be able to use any of the plot buttons appearing on top of the y-section (selected y variables, y-axis 
selections), it is needed to select at least one y-variable. Several variables can be selected from one or more 
files. The available files are listed in the area “Selected file” appearing at the bottom of this GUI. The user can 
switch from one file to the other by clicking on the file name. The highlighted file is the currently selected file. 
 
A sample plot with GUI functions resulting from the PLOT command is shown in Figure 3. It has several 
menus with self-explanatory functionalities. A useful menu is the “Copy” option. It copies the shown waveform 
to the clipboard and can be copied into any other application, including EMTPWorks. In addition to menus 
appearing on the top section of this figure, there could be one or more context (right-click) menus. These 
menus are explained below. 
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The selected scopes (variables) are given standard identification character strings separated by the “@” 
character. The first string is the variable name, the second string identifies the scope group of the variable and 
the third string is the file number following the order of the files appearing in the “Selected file” list. 
 
 
Most of the MPLOT options are self-explanatory. The following sections provide some guidelines to the user. 
 
In the following explanations y(i) refers to the ith selection in the y-section (y-axis selections) and y(:) means all 
selections in the y-section. This is also used for x and z. 
 
 

 

Figure 2 Main MPLOT panel 

scope 
names for 
the selected 
scope type 

y-axis selections 

x-axis selections 

z-axis selections 
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Figure 3 Sample plot 

 

2.2 The Data management buttons 
The first set of MPLOT buttons is used for data management. These buttons are located on the left side of the 
Main MPLOT panel and near the y, x and z sections. 

2.2.1 y>>  
This button is used to selected variables (scopes) from the area “scope names for the selected scope type” 
appearing on the left, and sending into the y-axis selections. The highlighted variables can be selected. More 
than one variable can be highlighted by holding the Shift or Ctrl buttons while clicking on the “scope names for 
the selected scope type”. 
It is also allowed to double-click on a given name in “scope names for the selected scope type” to make a 
selection. 

2.2.2 del y  
Select one or more variables in the list of variables appearing in the y-axis section and hit this key to remove 
them from the list. The Shift and Ctrl keys are applicable for selections. 

2.2.3 min max 
This button is used when a variable is appearing in both min and max scope groups from a statistical 
simulation. Hitting this button will automatically select both the min and the max of the variable. Only the min or 
the max needs to be highlighted in the “scope names for the selected scope type”. This option is only available 
for a statistical analysis plot file. 
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2.2.4 x>> button 
This button is used to select variables (scopes) from the area “scope names for the selected scope type” 
appearing on the left, and sending into the x-axis selections. The highlighted variables can be selected. More 
than one variable can be highlighted by holding the Shift or Ctrl keys while clicking on the “scope names for 
the selected scope type”. 

2.2.5 del x  
Select one or more variables in the list of variables appearing in the x-axis section and hit this key to remove 
them from the list. The Shift and Ctrl keys are applicable. 

2.2.6 z>> button 
This button is used to select variables (scopes) from the area “scope names for the selected scope type” 
appearing on the left, and sending into the z-axis selections. The highlighted variables can be selected. More 
than one variable can be highlighted by holding the Shift or Ctrl keys while clicking on the “scope names for 
the selected scope type”. 

2.2.7 del z 
Select one or more variables in the list of variables appearing in the z-axis section and hit this key to remove 
them from the list. The Shift and Ctrl keys are applicable. 

2.2.8 Add Data fields 
This function allows adding user defined data to the selected scope variable in “scope names for the selected 
scope type”. The currently available data is related to histogram count parameters. This function is available 
only for statistical analysis simulations.  
 

 

Figure 4 The “Add Data fields” panel 

 
In addition to the HISTC button described below, this data is used by other plot functions for the pu base and 
the optional tag name. 

2.2.9 Load Data fields 
This button loads all data fields created and saved in a previous section. There is only file holding data fields 
for each design. 
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2.3 The menus 

2.3.1 File>Open 
Is used to open new files and add them to the Selected file list at the bottom of the Main MPLOT panel. 

2.3.2 File>Save>y selections into a MAT file 
All y-axis selections are saved into a MATLAB MAT file. 

2.3.3 File>Save>y selections into an ASCII file 
All y-section selections are saved into an ASCII file. Each variable from y is saved into a user named file as 
columns of numbers. The default or selected x-axis data is saved in the first column.  

2.3.4 File>Save>user data fields 
This function saves user defined data fields into a standard file named var_data.fdt. This file is created and 
saved into the project directory of the simulation. There is only one file per design. An example of file contents 
is given by: 

BUS1a@vn_max 
BUS1a@vn 
188e03 
1 
0.05 
1.5 
BKR1a@vn_max 
BKR1a@vn 
188e03 
0 
0.05 
1 

 
The data fields are saved for each scope. Two scopes are shown in this example. The first line provides the 
variable (scope) identification. The following lines are taken from the “Add Data fields” data panel. 

2.3.5 File>Save>Random data for devices (y selections) 
This option is only available for statistical simulations. It is used for saving random data for the selected y-axis 
selection variables. Although any variable type can be saved, this function is useful for saving data for devices 
with random data generation functions, such as a switch with random opening or closing times. The saved 
data for the user selected simulation number can be used to replay in EMTP for reproducing the given 
simulation. An example of data file is given by: 

3 
SW1a 
0.0171948306322905 
SW1b 
0.0224214785728295 
SW1c 
0.0264999621912894 

 
The first line provides the number of devices (scopes) saved. The following line names the device. This name 
is the scope name and also the referenced device name. When a device is 3-phase and has separate data for 
each phase, the phase character must be appended to completely identify the device. The line following the 
device name provides the actual random data. One or more devices can be identified and followed by the 
corresponding data line. 
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If it is needed to reproduce the entire random simulation case, then all random data based devices must be 
saved.  

2.3.6 File>Load>User data fields 
This function loads back data fields saved in a previous session. 

2.3.7 File>Exit 
This function will close MPLOT and exit. 

2.3.8 Options>Reload Data 
This option is used to specify automatic reloading of data into MPLOT when the underlying simulation data has 
changed. 

2.3.9 Options>Use pu in bar type plots 
If this option is checked then bar type plots will read the pu data field of the selected y-axis section variable 
and provide the bar plot in pu. 

2.4 The plot buttons 
The plot buttons are those appearing on top of the y-section. 

2.4.1 Dump 
This button is only useful when MPLOT is used from MATLAB. It allows dumping x and y selections into the 
workspace. It can be used for powerful data manipulations through available functions. 

2.4.2 Clear 
This button is used to clear all selections in y, x and z sections. 

2.4.3 PLOT3 
This button allows creating 3D plots. The y, x and z sections must have selections to allow this function to 
operate. If the x-axis section is empty it will take the default data automatically. One or more selections can be 
made to appear on the same plot with a legend.  

2.4.4 PLOT 
This button allows creating a standard x-y line plot. It can plot several waveforms on the same axis. The 
waveforms are identified by a legend. 

2.4.5 SUBPLOT 
The SUBPLOT is similar to PLOT, only now each line is given its own axis. The last clicked axis is the one on 
which the plot GUI menus can operate. It operates only on x and y sections. 

2.4.6 ABSDIFF 
This function calculates and plots the absolute difference abs(y(1)-y(2)) and attempts to match the scale size 
and shift. Results could be wrong if the default x scales are not identical. 

2.4.7 MAXBAR 
Makes a bar plot for max(abs(y(:))) for each value of the x(1) vector. Optional pu usage from first shown y of 
each file is available. 
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2.4.8 ABSBAR 
Makes a bar plot for abs(y(:)) for each value of x(1) vector. Optional pu usage for y(:) is available. 

2.4.9 BAR 
Crates a bar plot from x(1) and y(:). Optional usage of pu for y(:) is available. 

2.4.10 Search 
Search data locations for selected value from max(abs(y(:))) and default x. Uses pu from first shown y of each 
file. A Search panel is used to specify the searched value and tolerance. This option is mostly useful for a 
statistical analysis case when searching for the simulation number that resulted in a searched value in y. 

2.4.11 CCDF 
Common Cumulative distribution function for vector max(abs(y(:))). This version concatenates files, which 
means that a common CDF from several files can be created. Uses optional pu data from first shown y of each 
file.  
The CDF plot is an empirical cumulative distribution function of the random observables in the data sample. 
This function is useful for a  statistical analysis simulation. 

2.4.12 CDF 
Cumulative distribution function for vector max(abs(y(:))). Each file is shown separately. Uses optional pu from 
first shown y of each file. 
This function is useful for a statistical analysis simulation. 

2.4.13 HISTC 
This button creates the histogram count plot for vector p=max(abs(y(:))). It uses "Data fields" from the first 
shown y of each file. It counts the number of values in the vector p that fall between the elements in the edges 
vector entered through data fields in Figure 4. 
If more than one file is present in the list for y-axis selections, then HISTC concatenates data from each file 
and calculates a unique histogram count. The edges vector used for showing the plot is the one taken from the 
last file’s first variable. HISTC assumes that concatenated data is compatible. 

3 Filter 
This field can be used to filter data listed in the “scope names for the selected scope type”. The user must click 
on the Enter key after typing a filter selection. Regular expressions can be used, such as 

PQ.*/ 

will select all scopes located in a subnetwork that starts with PQ characters in its name.  
The following metacharacters match exactly one character from its respective set of characters: 
. Any character 
[] Any character contained within the brackets 
[^] Any character not contained within the brackets 
\w A word character [a-z_A-Z0-9] 
\W Not a word character [^a-z_A-Z0-9] 
\d A digit [0-9] 
\D Not a digit [^0-9] 
The following metacharacters are used to logically group subexpressions or to specify context for a position in 
the match: 
() Group subexpression 
| Match subexpression before or after the | 
^ Match expression at the start of string 
$ Match expression at the end of string 
\< Match expression at the start of a word 
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\> Match expression at the end of a word 
The following metacharacters specify the number of times the previous metacharacter or grouped 
subexpression may be matched: 
* Match zero or more occurrences 
+ Match one or more occurrences 
? Match zero or one occurrence 
{n,m} Match between n and m occurrences 
Characters that are not special metacharacters are all treated literally in a match.  To match a character that is 
a special metacharacter, escape that character with a '\'. 

4 Context menus in the plot GUI 
An example of plot GUI is shown in Figure 3.  
The following context menus are available in this GUI: 

 For each line on any plot, a right-click (mouse) menu provides access to line settings. 
 For each legend line (the identification line) a right-click menu provides access to line and marking 

options. 
 For each legend text (the identification string) a right-click menu provides access to text settings. 
 For each text object created by the user, a right-click menu provides access to text settings. 

 
It is noticed that the context menus can be activated only when the zoom option is off. 

5 Zoom option 
The zoom option available in the plot GUI, can be activated using the toolbar (see Figure 3) or through the 
Zoom menu. To start zooming it is needed to click on the axis area, drag the left mouse button while holding it 
and releasing the left mouse button for the desired area. Double-clicking on the axis are, zooms out 
completely. The right-click can be used to zoom out slowly. 

6 Scripting 

6.1 Command file 
Most of the features available in the main MPLOT panel are also available through scripting for automatically 
opening graphs and performing other calculations. 
 
An ASCII file using the extension .txt is used to enter various commands to program automatic functions 
similar to manual pushing of buttons. 
 
The command file, named filedata.txt, for example, can be entered in the Extra files section of the opening 
MPLOT command shown in Figure 1. 
The main format of the command file is given as follows: 

File idenfitication section 
…. 
Configuration commands 
…. 
Plot Cases 

The command file is using MATLAB programming language syntax (m-file language). Only a specific set of 
commands is recognized and supported. 
 
The File identification section is used to enter the collection of Plot files used in various commands in the 
command file. There could be one or more Plot file selections. 
 
Configuration commands are used to specify various options. 
 



EMTP-EMTPWorks, 12/13/2017 1:15:00 AM  Page 11 of 16 

There could be one more sections specifying Plot Cases. Each Plot Case is a sequence of commands for 
specifying the type of plot and related data selections. 
 
The complete example shown in Figure 5 is used to explain available commands and options. 
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%Identify the files 
 filn{1}='parametric_pj/parametric1.m'; 
 filn{2}='parametric_pj/parametric2.m'; 
% 
Waitbar=0; %turn off waitbar when loading this data 
% 
%Perform Simple plot XY version using file 1 
PlotCase{1}.type='PLOT'; 
PlotCase{1}.var_y{1}='L1@vb@1'; 
PlotCase{1}.var_x{1}='L2@vb@1'; 
PlotCase{1}.Ylim=[0 0.3]; %for all data on this plot 
PlotCase{1}.Xlim=[-1 1]; %for all data on this plot 
% 
% 
%Perform 3D PLOT using files 1 and 2 
PlotCase{2}.type='PLOT3'; 
PlotCase{2}.var_y{1}='L1@vb@1'; 
PlotCase{2}.var_x{1}='L2@vb@1'; 
PlotCase{2}.var_z{1}='time@time@1'; 
% 
% 
% 
%Perform a min max extraction using an interval 
PlotCase{3}.type='MINMAX'; 
PlotCase{3}.var_y{1}='L1@vb@1'; 
PlotCase{3}.var_y{2}='L2@vb@1'; 
PlotCase{3}.interval_min(1)=1.5e-03; %separately specified for each y 
PlotCase{3}.interval_max(1)=5e-03; 
PlotCase{3}.filename='results.txt'; 
% 
%Perform a SUBPLOT using two different files 
PlotCase{4}.type='SUBPLOT'; 
PlotCase{4}.var_y{1}='L1@ib@1'; %first file 
PlotCase{4}.var_y{2}='L1@ib@2'; %second file 
% 
%Save Simple plot XY into a file 
PlotCase{5}.type='SAVEASCII'; 
PlotCase{5}.var_y{1}='L2@vb@1'; 
PlotCase{5}.var_y{2}='L2@vb@1'; 
PlotCase{5}.filename='a_plot.txt'; 
PlotCase{5}.Ylim=[0 0.3]; %for all data on this plot 

Figure 5 Sample command file 

1. In the file identification section, files are identified using the cell array named filn. It is allowed to use 
complete path names or relative path names. The relative paths are relative to the design file location 
or calling JavaScript command location discussed in the following section. 

2. The Waitbar command specifies that the waitbar should be turned off when loading data. Use 1 to turn 
it on. 

3. In the first Plot Case, the selected type is ‘PLOT’. This is equivalent to the PLOT pushbutton 
(command) in Figure 2. The selected y variable is 'L1@vb@1'. The selected x variable is 'L2@vb@1'. 

a. L1 stands for the device name 
b. vb indicates the branch voltage scopes group 
c. 1 means that file number 1 (filn{1}) is selected in the list of available files. 
d. There could be one or more y variables. 
e. There could be one or more x variables. 
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f. The Ylim field allows specifying the y-axis limits. 
g. The Xlim field allows specifying the x-axis limits. 
h. The Zlim field allows specifying the z-axis limits. 

4. In the second Plot Case, the selected type is ‘PLOT3’. This is equivalent to the PLOT3 command in 
Figure 2. 

a. In the PLOT3 case it is necessary to specify 3 variable selections. 
b. In this example, the third variable is the time scale. 

5. In the third Plot Case, the selected type is ‘MINMAX’. This command allows obtaining the minimum 
and the maximum x-y coordinates for a specified set of variables (y selections). 

a. Two variables are selected in this example. 
b. The search interval on the x-axis is specified using the fields interval_min and interval_max. A 

separate search interval can be specified for each variable using the variable index. If the 
search interval is omitted, the entire x-axis is selected. 

c. The output from the minimum and maximum computations must be stored in an ASCII file. In 
this case the selected file name (filename field) is ‘results.txt’. The format of this file is 
explained in the complete example given below. If there are several Plot Cases, then each 
case must use a different filename field. 

6. In the fourth Plot Case the type selection is 'SUBPLOT'. This is the same as the SUBPLOT command 
in Figure 2. 

7. In the fifth Plot Case the type selection is ‘SAVEASCII’. This is the same as the MPLOT based menu 
command File>Save>y selections into an ASCII file. 

a. The Xlim and Ylim fields are used for specifying x-axis and y-axis limits respectively. 
b. The filename field is used to specify the file where the plot data will be saved. The format of 

this file is simply a set of columns of data ordered according to the selected variable numbers. 
The default first column is simulation time. 

 
 
In addition to the above, there are other Plot Case type selection fields: 

1. SAVEASCIIy: is the same as File>Save>y and default x selections into an ASCII file 
2. SAVEMAT: is the same as the File>Save>y selections into a MAT file command 
3. BAR: is the same as the BAR command 
4. MAXBAR: is the same as the MAXBAR command 
5. ABSBAR: is the same as the ABSBAR command 
6. ABSDIFF: is the same as the ABSDIFF command 
7. Dump: is the same as the Dump command 

 
It is also allowed to use a wildcard for var_y. In the following example, the usage of '*@1' on the first selection 
var_y{1} requests to select all variables (all scopes) automatically. MPLOT detects this syntax and 
automatically creates the following cells in var_y for selecting all available scopes.  

PlotCase{1}.type='SAVEMAT'; 
PlotCase{1}.var_y{1}='*@1'; 
PlotCase{1}.filename='a_plot_all.mat'; 

In the above example, the mat file a_plot_all.mat will contain all scopes. 

6.2 Example with command file 
In the example shown in Figure 6, the Page Connectors are used to establish connection by name between 
the fault switch positive terminal and the connection points CIR1 or CIR2. In the first simulation CIR1 is 
connected to the fault switch by setting the name of the Page Connector of the FAULT_SWITCH to CIR1. The 
simulation is run and the simulation results are tagged as ‘1’ using “EMTP>View Output Files” and the Copy 
command. The circuit name is MPLOTparametric.ecf   
(see EMTPWorks\Examples\ShowHow\MPLOTsripts\PlotScripts for all files used in this section) and the 
corresponding tagged Plot file name becomes parametric1.m.  
 
The second simulation is run after naming the Page Connector of the FAULT_SWITCH CIR2. The waveforms 
are now preserved using the tag name ‘2’. This results into the Plot file parametric2.m. 
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The MPLOT command appearing in the design is set to open the command file named filedata.txt in the Extra 
files section. The contents of this file are shown in Figure 5.  
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Figure 6 Example of command file usage, design file parametric.ecf 

After opening the MPLOT device and clicking OK, MPLOT executes each Plot Case sequentially and opens all 
related windows automatically without opening the main MPLOT window shown in Figure 2. 
 
For the ‘MINMAX’ case, all results are stored in the specified results file named results.txt. The contents of this 
file are given below: 

function MPLOT_Data_Holder(){ 
this.name=''; 
this.miny=0; 
this.maxy=0; 
this.minx=0; 
this.maxx=0; 
this.interval_min=0; 
this.interval_max=0; 
} 
filename = new Array(); 
var V= new Array(); 
filename[0]='parametric_pj/parametric1.m'; 
filename[1]='parametric_pj/parametric2.m'; 
V[0]= new MPLOT_Data_Holder(); 
V[0].name='L1@vb@1'; 
V[0].miny=-0.354722735018; 
V[0].maxy=-0.030244895582; 
V[0].minx=0.0015; 
V[0].maxx=0.002005; 
V[0].interval_min=0.0015; 
V[0].interval_max=0.005; 
V[1]= new MPLOT_Data_Holder(); 
V[1].name='L2@vb@1'; 
V[1].miny=-0.94955320726; 
V[1].maxy=1.020168721; 
V[1].minx=0.04402; 
V[1].maxx=0.01395; 
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V[1].interval_min=0; 
V[1].interval_max=0; 

This file is designed for usage through JavaScript codes. It is a JavaScript code allowing to build the array of 
objects V. This array is holding all calculation results. The starting index is 0. The various Array fields are self-
explanatory.  
There is no messaging system when errors occur. The user must check the syntax of the code before running 
it. It is not allowed to use the same results file name more than once in a given command file. 
 
If a given command file is using several results files for different Plot Cases, then only the first results file will 
contain the function definition MPLOT_Data_Holder. 

6.3 Scripting with JavaScript  
The MPLOT device is a standard EMTPWorks device and it can be scripted using object methods. Complete 
information on the object definition is available in the main script file named mplot_i.dwj. Here is the list of 
available fields and methods. 
 

Object field Description 

BaseCaseCheck Checkbox for Base Case                                   

StatCaseCheck Checkbox for Statistical simulation data                 

ExtraTags Checkbox for Extra tagged files, '1' when on             

tags The tags (semicolumn separated tags) string              

ExtraFiles Checkbox for Extra files                                 

Files String for the list of files, separated by \n (new line) 

designpath Path of the design file (ends with \)                    

DesignFile Full file name (SPFile object)                          

project_dir project directory (ends with _pj)                        

myfiledates the Dates shown                                          

BaseCasePlotFile plot file for the base case (SPFile object)              

StatFile plot file for the stat case (SPFile object)              

waitmode  0 is default, will not wait after run, use -1 to wait   

SaveData Save Data method                                         

open Open method (double-click)                               

dev the selected device object                               

ExportDev not used                                                 

SaveFormData FormData is saved when true (default)                    

run The run method for this device (calls MPLOT package)     

 
The mplot_i.dwj script is the one executed when the MPLOT device is double-clicked in EMTPWorks. The 
object constructor function is  

var oDevice = new oDevice_mplot(dev); 

where dev is the targeted device. The mplot_i.dwj  script can be also started directly by using the command: 

parseScriptFile('mplot_i.dwj') 

This will result into the opening of the web shown in Figure 1.  
 
In the following example, the first line selects the current circuit. The second line locates the MPLOT device in 
the circuit. After locating the MPLOT device its methods ('mplot_i.dwj') are parsed and an instance of the 
object is created. The options of Figure 1 are selected by setting the corresponding object fields. The last 
command starts MPLOT for the selected options. 
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        cct=currentCircuit(); 
        dev=cct.devices('Script.Open.Dev','mplot_i.dwj'); //find MPLOT on the screen 
        dev=dev[0]; 
        parseScriptFile('mplot_m.dwj'); 
 
        // Create the object 
        var oDevice = new oDevice_mplot(dev); 
 
        // Start MPLOT to show only selected results 
        oDevice.ExtraTags='0'; 
        oDevice.ExtraFiles='1'; 
        oDevice.Files='filedata.txt'; //the relative path is done in MPLOT methods 
        oDevice.run(); //will call MPLOT and run 

 
An example of usage of the script file resulting from the ‘MINMAX’ case shown above is coded as: 

//Parse required methods     
parseScriptFile('check_my_filename.dwj'); //always needed, located in Info Scripts/device_services 
parseScriptFile('find_data_in_object.dwj'); //for searching object, located in Info Scripts/device_services 
 
// MPLOT has saved min and max data into results.txt 
parseScriptFile( check_my_filename('results.txt') ); 
//Now we have the V object, we can do a search 
 
i=find_data_in_object(V,'L2@vb@1'); 
alert('The minimum value (in the given interval) of branch voltage L2 is '+ V[i].miny); 

 
The two parseScriptFile commands are used to retrieve various services from the available EMTPWorks 
scripts. The third command establishes the complete file name of the output-script file and parses its contents. 
The V object is created and used in the find_data_in_object command to retrieve the desired scope. 
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